SQL injection and unserialization vulnerability in Relevanssi Premium could allow admins to execute arbitrary code (in some circumstances)

Score Vector Complexity Authentication Confidentiality Integrity Availability
9
High
Network Low Single Complete Complete Complete

You can read more about CVSS base scores on Wikipedia or in the CVSS specification.

Vulnerability

Relevanssi has a search function on the admin side that is not visible in the user interface, however the code is there and can be called. This functionality contains an sql injection, and this sql injection can be exploited to pass user controlled values into an unserialization call and run arbitrary code (if there are classes available with particular methods such as __destruct).

If a logged in admin user is tricked into going to an attacker controlled website, JavaScript could be written to make the admins browser submit the above request, without their knowledge. Alternatively this attack can be exploited by an attacker with Admin privileges.

Proof of concept

Achieving arbitrary code execution depends on which classes are available (i.e. which plugins and themes are installed and active). It won’t be possible in all situations.

Mitigation/further actions

Upgrade to version 1.14.6.1 or later.